Composer mit alternativer PHP Version starten

Wir haben einige Webserver mit Plesk, auf denen unterschiedliche PHP Versionen installiert sind. Die Standardinstallation unter /usr/bin/php wird vom Betriebssystem verwendet. Zusätzlich sind verschiedene Versionen untern /opt/plesk/php installiert. Über Plesk können wir sehr einfach pro gehosteter Website auswählen, welche php Version zum Einsatz kommen soll. Diese Änderung wirkt sich jedoch nicht aus auf das Betriebssystem aus. Hierdurch kann es zu Problemen bei der Verwendung von Composer kommen.

Bei der Installation von Magento erhalten wir bei der Installation unten stehende Fehlermeldung obwohl doch dem Webspace die richtige php Version zugewiesen wurde.

Starten der Installation:
composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition magento

Fehlermeldung:

php-cs-fixer v1.10 requires php >=5.3.6 -> your PHP version (5.3.3) does not satisfy that requirement.

Dies lässt sich ganz einfach umgehen, in dem wir Composer mit der php Version starten, die auch dem Betriebssystem zugewiesen wurde:

export PATH=/opt/plesk/php/5.6/bin:$PATH; composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition magento

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.